summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2022-06-17 01:42:26 +0800
committerUniversebenzene2022-06-17 01:42:26 +0800
commit4426e68010e04598226c0d59ba77b51800cd41bf (patch)
tree3cf8b62ec38d6c3e791eabb271a7d6ba8b55f567 /PKGBUILD
parentf1ade99887ae333a3e572694a26a9398427df12e (diff)
downloadaur-4426e68010e04598226c0d59ba77b51800cd41bf.tar.gz
Update to version 1.2.32
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5da9782150e3..2ddf343755f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,19 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
+
pkgbase=python-sunpy-sphinx-theme
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=1.2.30
+pkgver=1.2.32
pkgrel=1
pkgdesc="The sphinx theme for the SunPy website and documentation"
arch=('any')
url="https://github.com/sunpy/sunpy-sphinx-theme"
license=('BSD')
makedepends=('python-setuptools-scm' 'python-wheel' 'python-build' 'python-installer')
-#checkdepends=('python-pytest' 'python-sphinx' 'python-sphinx-bootstrap-theme')
-checkdepends=('python-nose' 'python-sunpy')
-source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
- 'setup.py')
-md5sums=('97931ecefb1dc5f7c645e48516abd0f0'
- '8bbd0e92c81e8eb3b0a9ba9977198c8d')
-
-prepare() {
- cd ${srcdir}/${_pyname}-${pkgver}
-
- ln -rs ${srcdir}/setup.py .
-}
+#checkdepends=('python-pytest' 'python-sphinx')
+checkdepends=('python-nose' 'python-sphinx-bootstrap-theme')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
+md5sums=('70964489bf74272cd1647a5f0c788b6c')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -31,7 +24,6 @@ build() {
check() {
cd ${srcdir}/${_pyname}-${pkgver}
-# python setup.py test
# pytest
nosetests
}