summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2022-05-08 17:33:11 +0800
committerUniversebenzene2022-05-08 17:33:11 +0800
commitf1ade99887ae333a3e572694a26a9398427df12e (patch)
treee5bd65649e651a2854a75eb7d6cbd0a37f28970c /PKGBUILD
parent30d6b144216b925ba2b0b4fa2657569eea002b43 (diff)
downloadaur-f1ade99887ae333a3e572694a26a9398427df12e.tar.gz
Update to version 1.2.30
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 19 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3593702bd96..5da9782150e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=python-sunpy-sphinx-theme
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=1.2.29
+pkgver=1.2.30
pkgrel=1
pkgdesc="The sphinx theme for the SunPy website and documentation"
arch=('any')
@@ -10,8 +10,17 @@ url="https://github.com/sunpy/sunpy-sphinx-theme"
license=('BSD')
makedepends=('python-setuptools-scm' 'python-wheel' 'python-build' 'python-installer')
#checkdepends=('python-pytest' 'python-sphinx' 'python-sphinx-bootstrap-theme')
-source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('f4bb546e9206c770524c8c2a5661e682')
+checkdepends=('python-nose' 'python-sunpy')
+source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
+ 'setup.py')
+md5sums=('97931ecefb1dc5f7c645e48516abd0f0'
+ '8bbd0e92c81e8eb3b0a9ba9977198c8d')
+
+prepare() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+ ln -rs ${srcdir}/setup.py .
+}
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -19,12 +28,13 @@ build() {
python -m build --wheel --no-isolation
}
-#check() {
-# cd ${srcdir}/${_pyname}-${pkgver}
-#
-# python setup.py test
-## pytest
-#}
+check() {
+ cd ${srcdir}/${_pyname}-${pkgver}
+
+# python setup.py test
+# pytest
+ nosetests
+}
package_python-sunpy-sphinx-theme() {
depends=('python-sphinx' 'python-sphinx-bootstrap-theme')