summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Handley2023-01-23 13:59:43 +0000
committerWill Handley2023-01-23 13:59:43 +0000
commit0f59f648b26a5f877ca302dba93680cca4bb276a (patch)
tree76193e88ab5bac475207887241859f31c91e1294 /PKGBUILD
downloadaur-0f59f648b26a5f877ca302dba93680cca4bb276a.tar.gz
0.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7791a0d6c280
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=python-swyft
+_name=${pkgname#python-}
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="swyft is the official implementation of Truncated Marginal Neural Ratio Estimation (TMNRE), a hyper-efficient, simulation-based inference technique for complex data and expensive simulators."
+arch=(any)
+url="https://github.com/undark-lab/swyft"
+license=('Apache')
+groups=()
+depends=(python-toolz python-numpy python-torch python-pytorch_lightning python-zarr python-matplotlib python-scipy python-torchist python-fasteners)
+makedepends=(python-build python-installer)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(5b19514d6a114f7a768e96240026091db87a68495e1c43a212acf3dd842fd3e2)
+
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+