summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsfmajors3732019-06-27 08:50:58 -0400
committersfmajors3732019-06-27 08:50:58 -0400
commit6d873c7ab0f120e4551e10a98ed484bfeb9c1241 (patch)
tree42fc52c202cf6e17b8543e3705c9a7b994db49c5 /PKGBUILD
downloadaur-6d873c7ab0f120e4551e10a98ed484bfeb9c1241.tar.gz
Generated syft package using pipman-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e64594375764
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# PKGBUILD generated by pipman
+# Python package author: Andrew Trask <contact@openmined.org>
+pkgname=python-syft
+pkgver=0.1.19a1
+pkgrel=1
+pkgdesc="A Library for Private, Secure Deep Learning"
+arch=(any)
+url="https://github.com/OpenMined/PySyft"
+license=(Apache-2.0)
+makedepends=("python" "python-pip")
+build() {
+ pip install --no-deps --target="syft" syft==0.1.19a1
+}
+package() {
+ sitepackages=$(python -c "import site; print(site.getsitepackages()[0])")
+ mkdir -p $pkgdir/"$sitepackages"
+ cp -r $srcdir/syft/* $pkgdir/"$sitepackages"
+} \ No newline at end of file