summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGeorg Schlisio2017-08-02 09:01:57 +0200
committerGeorg Schlisio2017-08-02 09:01:57 +0200
commit2f1d6bb877a11cebc074bc55d5a44b1619d29d89 (patch)
tree705d315f0eb15d13c2c8f0eaa3c95ec8e3067ff7 /PKGBUILD
downloadaur-2f1d6bb877a11cebc074bc55d5a44b1619d29d89.tar.gz
0.3.7, initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..530527402615
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=("python-symfit" "python2-symfit")
+pkgbase=python-symfit
+pkgver=0.3.7
+pkgrel=1
+pkgdesc='Symbolic fitting for python - fitting as it should be'
+arch=('any')
+url='https://github.com/tBuLi/symfit'
+makedepends=('python-setuptools' 'python2-setuptools')
+license=('GPL2')
+source=("https://github.com/tBuLi/symfit/archive/$pkgver.tar.gz")
+md5sums=('3883a3fe1e30425006ed622f2f620440')
+
+
+package_python-symfit() {
+ depends=('python' 'python-numpy' 'python-sympy')
+ cd "$srcdir/symfit-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-symfit() {
+ depends=('python2' 'python2-numpy' 'python2-sympy')
+ cd "$srcdir/symfit-$pkgver"
+ #find . -name "*.py" -exec sed -i 's#/usr/bin/env python#/usr/bin/env python2#' {} \;
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}