summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPekka Ristola2023-09-15 10:30:15 +0300
committerPekka Ristola2023-09-15 10:30:15 +0300
commit47a2e04e21855bdfaa531975442166cf75985d30 (patch)
treef8ed17863ab259603c402f852b9b2bbc8ed354af /PKGBUILD
parentd09681e97cf1cbd9f961c4bfc9098605f62c5737 (diff)
downloadaur-47a2e04e21855bdfaa531975442166cf75985d30.tar.gz
Update to 0.6.0
- update upstream URL (the old URL redirects to the new URL) - remove unnecessary `conflicts` array - remove workaround for python-poetry-core bug that was fixed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4602bd4e349e..b296c78041ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,23 @@
pkgname=python-syncedlyrics
_pkgname=syncedlyrics
-pkgver=0.5.0
-pkgrel=2
+pkgver=0.6.0
+pkgrel=1
pkgdesc='Get an LRC format (synchronized) lyrics for your music'
arch=('any')
-url='https://github.com/rtcq/syncedlyrics'
+url="https://github.com/0x7d4/syncedlyrics"
license=('MIT')
depends=('python>=3.7' 'python-requests>=2.28.1' 'python-rapidfuzz>=2.13.2'
'python-beautifulsoup4>=4.11.1')
makedepends=('python-build' 'python-installer' 'python-wheel'
'python-poetry-core')
checkdepends=('python-pytest')
-conflicts=("${pkgname}-git")
-source=("${_pkgname}-${pkgver}".tar.gz::"https://github.com/rtcq/${_pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('82d4315d753875c8e483dfad95e9c13bc5136fbd62e06bda6ce7b33b18c1fe26')
+source=("$_pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('26491289f332d8a986eda844472ae72d9d15c7f7456dced628b27f325a98329b')
build() {
cd "${srcdir}/${_pkgname}-${pkgver}"
- GIT_DIR=. python -m build --wheel --no-isolation
+ python -m build --wheel --no-isolation
}
check() {