summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTed Alff2019-05-19 11:05:07 -0400
committerTed Alff2019-05-19 11:05:07 -0400
commitf4f7672ea0cacf11d5d546f99b7215b936fec93b (patch)
treebe348ac35711a358c34ed8899b3d7d3d8fb3c741 /PKGBUILD
downloadaur-f4f7672ea0cacf11d5d546f99b7215b936fec93b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a302c9f6ef8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: twa022 <twa022 at gmail dot com>
+
+pkgname=python-system_hotkey
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Python library for system wide hotkeys"
+arch=('any')
+url="https://github.com/timeyyy/system_hotkey"
+license=('BSD')
+depends=('python-xcffib')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/timeyyy/${pkgname/python-/}/archive/${pkgver}.tar.gz")
+sha256sums=('4d6e06bf359efecf4bea251e330c852f83b9150f503df28fd94239499f4ff606')
+
+package() {
+ cd "${srcdir}/${pkgname/python-/}-${pkgver}"
+ python setup.py install --root="${pkgdir}"
+
+ install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 "${srcdir}/${pkgname/python-/}-${pkgver}/LICENSE"
+}