summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNarrat2022-07-31 21:04:08 +0200
committerNarrat2022-07-31 21:04:08 +0200
commit5c95b3276b67a5f85e459f10851a39734b16c9c1 (patch)
treec41f7ba0ed66c4b03212f37258649ca86894eb32 /PKGBUILD
parentdd7a2f429f8b5138cd2822f544afe1e4d4360230 (diff)
downloadaur-5c95b3276b67a5f85e459f10851a39734b16c9c1.tar.gz
python-tablib: PEP 517
which requires one additional makedep in form of python-setuptools-scm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 719c81fb2bba..a31c2af5b459 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
_module="tablib"
pkgname="python-${_module}"
pkgver=3.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Format-agnostic tabular data library (XLS, JSON, YAML, CSV)"
arch=("any")
url="http://python-tablib.org"
license=("MIT")
-depends=("python")
-makedepends=("python-pip" "python-setuptools")
+depends=(python)
+makedepends=(python-build python-installer python-wheel python-setuptools-scm)
checkdepends=("python-pytest-cov" "python-tabulate" "python-markuppy"
"python-odfpy" "python-pandas" "python-xlrd"
"python-xlwt" "python-openpyxl" "python-pyaml")
@@ -28,7 +28,7 @@ sha256sums=('a57f2770b8c225febec1cb1e65012a69cf30dd28be810e0ff98d024768c7d0f1')
build() {
cd "${_module}-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -38,7 +38,7 @@ check() {
package() {
cd "${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -D -m644 "${srcdir}/${_module}-${pkgver}/LICENSE" \
"${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}