summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2021-10-16 16:20:18 +1100
committerMatthew Gamble2021-10-16 16:20:40 +1100
commit544081924adc4a834258c0eeb78acee4a77eb20d (patch)
tree2dc0d090753bcd089a4a6872e77b99668d1a0883 /PKGBUILD
parentab8dc9f114b80b41ef0079d76a6488a5041d0fc9 (diff)
downloadaur-544081924adc4a834258c0eeb78acee4a77eb20d.tar.gz
Update to latest release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 22 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 77df8e1e04e2..0090f287e7c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
-# Contributor: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
-# Maintainer: Nathan Owens <ndowens @ artixlinux.org>
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+# Contributor: Nathan Owens <ndowens @ artixlinux.org>
+# Contributor: carstene1ns <arch carsten-teibes de>
pkgname=python-tatsu
-pkgver=5.0.0
+pkgver=5.6.1
pkgrel=1
-pkgdesc="A tool that takes grammars in a variation of EBNF as input, and outputs memoizing (Packrat) PEG parsers in Python"
-arch=('any')
+pkgdesc="TatSu takes a grammar in a variation of EBNF as input, and outputs a memoizing PEG/Packrat parser in Python."
+arch=("any")
url="https://github.com/neogeny/TatSu"
-license=('BSD')
-depends=('python')
-makedepends=('python-setuptools'
- 'git')
-source=("git+https://github.com/neogeny/TatSu#tag=v$pkgver")
-sha256sums=('SKIP')
+license=("BSD")
+depends=("python")
+optdepends=("python-regex")
+makedepends=('python-setuptools')
+source=("https://pypi.io/packages/source/T/TatSu/TatSu-${pkgver}.zip")
+sha256sums=("6a4f07aa7bfe9dfbee8015824feaf13f0b1a89577e2ee5a4a62c18630c309d4e")
-package() {
- cd "$srcdir/TatSu"
+build() {
+ cd "TatSu-${pkgver}"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python setup.py build
+}
- rm -rf "$pkgdir"/usr/lib/python3.*/site-packages/test
+package() {
+ cd "TatSu-${pkgver}"
- install -Dm644 README.rst "$pkgdir"/usr/share/doc/$pkgname/README.rst
- install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/python-tatsu/LICENSE.txt"
+ install -Dm644 README.rst "${pkgdir}/usr/share/doc/python-tatsu/README.rst"
+ install -Dm644 CHANGELOG.rst "${pkgdir}/usr/share/doc/python-tatsu/CHANGELOG.rst"
}