diff options
author | Philipp A | 2022-02-19 16:20:49 +0100 |
---|---|---|
committer | Philipp A | 2022-02-19 16:20:49 +0100 |
commit | e639f3bf6c5e9461d933d2f4a0d219d2f8df9b0c (patch) | |
tree | bf2cfe4001e205b06e26ea6b3e662e1ac3f803aa /PKGBUILD | |
parent | 650921a6c45d95321187f1bd9acc7e2372c931ab (diff) | |
download | aur-e639f3bf6c5e9461d933d2f4a0d219d2f8df9b0c.tar.gz |
build from source
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 20 |
1 files changed, 10 insertions, 10 deletions
@@ -9,16 +9,16 @@ arch=(any) url="https://github.com/skorokithakis/$_name" license=(MIT) depends=(python) -makedepends=(install-wheel-scripts) -_pyarch=py2.py3 -_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl" -source=("https://files.pythonhosted.org/packages/3.6/${_name::1}/$_name/$_wheel") -sha256sums=('3aae41b75e237f2840dde274722b1070ca43d65dd24cf60344bd6d345c77cc3d') -noextract=("$_wheel") +makedepends=(python-build python-installer) +source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz") +sha256sums=('8665d037ac8ad4c97bc44512de91798565b1226f7b2f59669bb7dbe9a1f87718') + +build() { + cd "$_name-$pkgver" + python -m build --wheel --no-isolation +} package() { - local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages" - mkdir -p "$site" - unzip "$_wheel" -d "$site" - install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel" + cd "$_name-$pkgver" + python -m installer --destdir="$pkgdir" dist/*.whl } |