summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-02-05 19:54:01 -0600
committerLuis Martinez2022-02-05 19:54:01 -0600
commit180e01f9ff8435e5b924034c83465011ecd3953d (patch)
treefea0e0e4bc6883926afc0c76d891a4bf9faeb39e /PKGBUILD
parentea8893a81b6ca0f0bdb1b912dcd41558be0af0de (diff)
downloadaur-180e01f9ff8435e5b924034c83465011ecd3953d.tar.gz
update to 13.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af9852820dbe..ba1b78a56a31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
## Cannot use libtcod as dependency; statically linked
pkgname=python-tcod
-pkgver=13.3.0
+pkgver=13.4.0
pkgrel=1
pkgdesc='High-performance Python port of libtcod'
arch=('x86_64')
@@ -13,14 +13,12 @@ url='https://github.com/libtcod/python-tcod'
license=('BSD')
depends=('python-cffi' 'python-numpy' 'python-typing_extensions' 'sdl2')
makedepends=(
- 'git'
- 'python-setuptools'
- 'python-pytest-runner'
- 'python-pycparser'
- 'python-sphinx')
+ 'git' 'python-setuptools' 'python-build' 'python-install' 'python-wheel'
+ 'python-pytest-runner' 'python-pycparser' 'python-pcpp' 'python-sphinx')
changelog=CHANGELOG.md
-source=("$pkgname::git+$url#tag=$pkgver?signed"
- 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.20.1?signed')
+source=(
+ "$pkgname::git+$url#tag=$pkgver?signed"
+ 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.20.1?signed')
sha256sums=('SKIP'
'SKIP')
validpgpkeys=('9EF1E80F3817BC043097A7C15814977902B194CC') # Kyle Benesch @ GitHub
@@ -34,7 +32,7 @@ prepare() {
build() {
cd "$pkgname"
- python setup.py build
+ python -m build --wheel --skip-dependency-check --no-isolation
cd docs
make man
}
@@ -46,8 +44,9 @@ build() {
# }
package() {
+ export PYTHONHASHSEED=0
cd "$pkgname"
- PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ python -m install --optimize=1 --destdir="$pkgdir/" dist/*.whl
install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm644 docs/_build/man/python-tcod.1 -t "$pkgdir/usr/share/man/man1/"
}