summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2022-01-09 01:55:35 -0600
committerLuis Martinez2022-01-09 01:55:35 -0600
commitea8893a81b6ca0f0bdb1b912dcd41558be0af0de (patch)
treee38a53e66a629bc11b16a1c50d35939b22cd681a /PKGBUILD
parent51d59f3da0348305862aec7f56e0623977ad0e9a (diff)
downloadaur-ea8893a81b6ca0f0bdb1b912dcd41558be0af0de.tar.gz
update to 13.3.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c4ef07e8a1c..af9852820dbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,36 +5,35 @@
## Cannot use libtcod as dependency; statically linked
pkgname=python-tcod
-pkgver=13.2.0
+pkgver=13.3.0
pkgrel=1
pkgdesc='High-performance Python port of libtcod'
arch=('x86_64')
url='https://github.com/libtcod/python-tcod'
license=('BSD')
-depends=('python-cffi' 'python-numpy' 'python-typing_extensions')
+depends=('python-cffi' 'python-numpy' 'python-typing_extensions' 'sdl2')
makedepends=(
'git'
'python-setuptools'
'python-pytest-runner'
'python-pycparser'
- 'python-sphinx'
- 'sdl2')
-changelog=CHANGELOG.rst
-source=("$pkgname-$pkgver::git+$url#tag=$pkgver?signed"
- 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.20.0?signed')
+ 'python-sphinx')
+changelog=CHANGELOG.md
+source=("$pkgname::git+$url#tag=$pkgver?signed"
+ 'libtcod::git+https://github.com/libtcod/libtcod#tag=1.20.1?signed')
sha256sums=('SKIP'
'SKIP')
validpgpkeys=('9EF1E80F3817BC043097A7C15814977902B194CC') # Kyle Benesch @ GitHub
prepare() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
git submodule init
git config submodule.libtcod.url "$srcdir/libtcod"
git submodule update
}
build() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
python setup.py build
cd docs
make man
@@ -47,7 +46,7 @@ build() {
# }
package() {
- cd "$pkgname-$pkgver"
+ cd "$pkgname"
PYTHONHASHSEED=0 python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
install -Dm644 LICENSE.txt -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm644 docs/_build/man/python-tcod.1 -t "$pkgdir/usr/share/man/man1/"