summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuis Martinez2023-01-01 17:46:09 -0600
committerLuis Martinez2023-01-01 17:46:09 -0600
commitdc6030c682576fa5c7bcf8f8bc8aec96b108b251 (patch)
tree1c0a15bdd6eb6f05f95fa3a2a02615587753186b /PKGBUILD
parentcd3b2b2ec60131665582f9ea65c026d845ad3a11 (diff)
downloadaur-dc6030c682576fa5c7bcf8f8bc8aec96b108b251.tar.gz
hotfix for packaging
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 08c4f10b31b8..a3555c1ff986 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
pkgname=python-technical
+_pkg="${pkgname#python-}"
pkgver=1.3.0
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc='Various indicators developed or collected for the freqtrade'
url='https://github.com/freqtrade/technical'
@@ -14,25 +15,24 @@ checkdepends=('python-pytest' 'python-mock')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
'remove-tests.patch')
sha256sums=('8604750f1aced810c320a0a844f91511ae807bce8701d1599afedebef38b4aaa'
- 'f819291c544fe57d547c6e5e37fde4304bf72c89843bbd419e18c0dd3640ef03')
+ '6ab0c2b27b1d9a8c3006c364c4ec26352d1efec2c432ec776008b4f88723883a')
prepare() {
- patch -p1 -d "technical-$pkgver" < remove-tests.patch
+ patch -p1 -d "$_pkg-$pkgver" < remove-tests.patch
}
build() {
- cd "technical-$pkgver"
+ cd "$_pkg-$pkgver"
python -m build --wheel --no-isolation
}
check() {
- cd "technical-$pkgver"
+ cd "$_pkg-$pkgver"
pytest -x --disable-warnings
}
package() {
- export PYTHONHASHSEED=0
- cd "technical-$pkgver"
+ cd "$_pkg-$pkgver"
python -m installer --destdir="$pkgdir/" dist/*.whl
- install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dvm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
}