summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBjörn Bidar2018-12-12 22:51:44 +0100
committerBjörn Bidar2018-12-12 22:52:31 +0100
commita6451da5116448b1fc919d88a45b2096f0db42d9 (patch)
tree5e03b209ac37baf220737dff3e9391324fdf5b18 /PKGBUILD
downloadaur-a6451da5116448b1fc919d88a45b2096f0db42d9.tar.gz
init commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c49a1c85583e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Thaodan <theodorstormgrade@gmai.com>
+_pkgname=TelegramUserMapBot
+pkgname=python-${_pkgname,,}-git
+pkgrel=1
+pkgver=r29.e2ab1e7
+pkgdesc="A Telegram Bot to collect location information from users and export the coordinates to a map service."
+url="https://github.com/Thaodan/$_pkgname"
+arch=('any')
+license=('GPL3')
+depends=('python-peewee' 'python-telegram-bot')
+source=(git+https://github.com/Thaodan/$_pkgname#branch=merger)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build()
+{
+ cd "$srcdir/$_pkgname"
+ python setup.py build
+}
+
+
+package() {
+ cd "$srcdir/$_pkgname"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -Dm755 $_pkgname.service "$pkgdir"/usr/lib/systemd/system/$_pkgname.service
+ install -dm755 "$pkgdir"/etc/_$pkgname
+}
+md5sums=('SKIP')