summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2023-10-13 05:23:41 +0800
committerlilac2023-10-13 05:23:41 +0800
commit4a2856f9e7c15987e3108c81c3489b7d08a5f8d4 (patch)
tree7524a08a198e01f2dd1a3988f1b585c6da0726c7 /PKGBUILD
parentf2dfee2dd2cbc78bf6a6ef8b7e28af56331b242e (diff)
downloadaur-4a2856f9e7c15987e3108c81c3489b7d08a5f8d4.tar.gz
[lilac] updated to 1.31.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fef3822b5c8c..c889cdd3bb37 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=Telethon
pkgname=python-telethon
-pkgver=1.30.3
+pkgver=1.31.0
pkgrel=1
pkgdesc="Full-featured Telegram client library for Python 3"
arch=(any)
@@ -8,16 +8,16 @@ url="https://github.com/LonamiWebs/Telethon"
license=('MIT')
depends=('python-pyaes' 'python-rsa')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.30.3.tar.gz")
-sha256sums=('313e40fa06667b19ced13b379d9988167a8319bc0eb90bf39347cff46919a351')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/Telethon-1.31.0.tar.gz")
+sha256sums=('8c2a2e0398e329323bd6d2a6c1d3964f85e882d557144b77edb8ff969916ff5b')
build() {
- cd "$srcdir/Telethon-1.30.3"
+ cd "$srcdir/Telethon-1.31.0"
python3 setup.py build
}
package() {
- cd "$srcdir/Telethon-1.30.3"
+ cd "$srcdir/Telethon-1.31.0"
python3 setup.py install --root=$pkgdir --optimize=1 --skip-build
# make sure we don't install any world-writable or root-readable-only files