summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Elkouby2018-05-05 14:18:49 +0300
committerDan Elkouby2018-05-05 14:20:18 +0300
commit6f0923d62b724da9f64584b69c94da9537385064 (patch)
tree82f587f21db3242ab85f1b7f9db9d4d402033f24 /PKGBUILD
downloadaur-6f0923d62b724da9f64584b69c94da9537385064.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb1d3657f71c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Dan Elkouby <streetwalrus@codewalr.us>
+pkgname=python-telethon-aio-git
+pkgver=20180428.d693535
+pkgrel=1
+pkgdesc="Pure Python 3 Telegram client library, asyncio version"
+arch=('any')
+url="https://github.com/LonamiWebs/Telethon/"
+license=('MIT')
+depends=('python>=3.5' 'python-pyaes' 'python-rsa')
+makedepends=('python-setuptools')
+conflicts=('python-telethon')
+options=(!emptydirs)
+source=("git+https://github.com/LonamiWebs/Telethon.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/Telethon"
+ git log -1 --format='%cd.%h' --date=short | tr -d -
+}
+
+build() {
+ cd "$srcdir/Telethon"
+ ./setup.py build
+}
+
+package() {
+ cd "$srcdir/Telethon"
+ ./setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE.rst"
+}
+
+# vim:set ts=2 sw=2 et: