summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Holthuis2015-06-21 19:42:28 +0200
committerJan Holthuis2015-06-21 19:42:28 +0200
commitd15f59a2574ceb4e6313359b5e08e2af42e6142a (patch)
treed9d448dc7839959e812f68999f180816324822e8 /PKGBUILD
downloadaur-python-tempmail.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e56dabfbf34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Jan Holthuis <holthuis.jan@googlemail.com>
+
+pkgname=python-tempmail
+_pypiname=temp-mail
+pkgver=0.2
+pkgrel=1
+pkgdesc="Wrapper for online service which provides temporary email address: https://temp-mail.ru/"
+arch=('any')
+url="https://github.com/saippuakauppias/temp-mail"
+license=('MIT')
+depends=('python'
+ 'python-requests')
+makedepends=('python-setuptools')
+optdepends=('python-simplejson: For a serious speed boost in JSON decode')
+conflics=('python-tempmail-git')
+provides=('python-tempmail')
+source=("https://pypi.python.org/packages/source/t/${_pypiname}/${_pypiname}-${pkgver}.tar.gz")
+md5sums=('f625c6b699769cd83b133fdc8d5bec92')
+
+package() {
+ cd "$srcdir/$_pypiname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+} \ No newline at end of file