summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Handley2022-06-07 21:22:11 +0100
committerWill Handley2022-06-07 21:22:11 +0100
commit91502a9d855ec013e4c727165b0e2a0104539387 (patch)
tree1d1c0bb80ee5ffd45e367a9514c5b033ddccf7b1 /PKGBUILD
parent4ffc256f5e559a6db5c9518b24cb39771faf54b9 (diff)
downloadaur-91502a9d855ec013e4c727165b0e2a0104539387.tar.gz
Updated
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1f490b33ff9..ca85b9b464fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
-_modulename=texsoup
-pkgname=python-$_modulename
+pkgname=python-texsoup
+_name=TexSoup
pkgver=0.3.1
-pkgrel=2
+pkgrel=4
pkgdesc="Python3 package for searching, navigating, and modifying LaTeX documents using BeautifulSoup-esque idioms"
arch=(any)
url="https://github.com/alvinwan/TexSoup"
@@ -16,9 +16,15 @@ replaces=()
backup=()
options=(!emptydirs)
install=
-source=("${url}/archive/${pkgver}.tar.gz")
-sha256sums=('3c093e9634675436ff0cfcc9cd116722577613957b11a6285518f51c39a90784')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(3f6b2ad0abe3688a6656f544c1ba04d0eb25f423f8c377b7369f9ce061ddb70b)
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd "$srcdir/TexSoup-$pkgver/"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}
+