summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Borders2019-11-26 14:54:33 -0500
committerMichael Borders2019-11-26 14:54:33 -0500
commit98ce029af90389dafcbef3f429deb478b8316fc2 (patch)
tree801e130cb615fee8df57c13513372bfd2a44d438 /PKGBUILD
parent37530c197d9d950e11f5c38db765731e04c7fb61 (diff)
downloadaur-python-textfsm.tar.gz
Added check before install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fbf8ae8cf509..8160a842a9e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,21 @@ pkgname=python-textfsm
_pkgname=textfsm
pkgver=1.1.1
_pkgver="v${pkgver}"
-pkgrel=2
+pkgrel=3
pkgdesc="Python module for parsing semi-structured text into python tables."
arch=('any')
url="https://github.com/google/textfsm"
license=('Apache')
depends=('python')
-optdepends=()
makedepends=('python-setuptools')
source=("${url}/archive/${_pkgver}.tar.gz")
sha256sums=('9299d54544b679ef2a477c9256ec5e906c649f8f79593b71d2bb56e1c96e6601')
+check() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py test
+}
+
package(){
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1