summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Borders2019-11-16 15:05:04 -0500
committerMichael Borders2019-11-16 15:05:04 -0500
commit26723f3bafcf4dbadc0daf3a32f8a4cf387d13f2 (patch)
tree6d60e4512509088c862ab1defb5ea0e8e46ddbd5 /PKGBUILD
downloadaur-26723f3bafcf4dbadc0daf3a32f8a4cf387d13f2.tar.gz
Initial commit, v1.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c05892467a24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Michael Borders <michael.a.borders@gmail.com>
+
+pkgname=python-textfsm
+_pkgname=textfsm
+pkgver=1.1.0
+_pkgver="v${pkgver}"
+pkgrel=1
+pkgdesc="Python module for parsing semi-structured text into python tables."
+arch=('any')
+url="https://github.com/google/textfsm"
+license=('Apache')
+depends=('python')
+optdepends=()
+makedepends=('python-setuptools')
+source=("${url}/archive/${_pkgver}.tar.gz")
+sha256sums=('b750de2986ef78696e686b510a96aa23206a575580daf2b1eb7e17525ed33045')
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}