summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiretza2022-08-20 23:38:36 +0200
committerXiretza2022-08-20 23:39:57 +0200
commit1248445f4c486b9b446c97a585b295df6b1136f8 (patch)
tree53cc721ae33e9e5d28a3b52ccf23d2a2cf0645e3 /PKGBUILD
parent9d934b584ca96187aec0c28c802282a71ce258f7 (diff)
downloadaur-1248445f4c486b9b446c97a585b295df6b1136f8.tar.gz
Use PEP 517 build workflow
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 558b3c70e5b3..a3f43f2cde5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,20 +4,21 @@
pkgname=python-textx
_srcname=textX
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Python library for building Domain-Specific Languages and parsers"
arch=('any')
url="https://textx.github.io/textX/"
license=('MIT')
depends=('python' 'python-setuptools' 'python-arpeggio' 'python-future')
optdepends=('python-click: textX CLI support')
+makedepends=('python-build' 'python-installer' 'python-wheel')
checkdepends=('python-pytest-runner' 'python-pip' 'python-jinja' 'python-click' 'python-html5lib')
source=("$pkgname-$pkgver.tar.gz::https://github.com/textX/$_srcname/archive/$pkgver.tar.gz")
md5sums=('6d868822583d86f66cda71f40b1bebb5')
build() {
cd $_srcname-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
@@ -51,7 +52,7 @@ check() {
package() {
cd "$srcdir/$_srcname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}