summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXiretza2022-08-20 23:35:23 +0200
committerXiretza2022-08-20 23:35:23 +0200
commit9d934b584ca96187aec0c28c802282a71ce258f7 (patch)
tree295b714e3267592ae32a2028368739f384e183b0 /PKGBUILD
parentf3e83a29fd0f7dae789762f09fa959d3f2072c19 (diff)
downloadaur-9d934b584ca96187aec0c28c802282a71ce258f7.tar.gz
Update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 10 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e2fce00236fa..558b3c70e5b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,11 +9,10 @@ pkgdesc="Python library for building Domain-Specific Languages and parsers"
arch=('any')
url="https://textx.github.io/textX/"
license=('MIT')
-depends=('python' 'python-arpeggio' )
+depends=('python' 'python-setuptools' 'python-arpeggio' 'python-future')
optdepends=('python-click: textX CLI support')
-makedepends=('python-setuptools')
-checkdepends=('python-pytest-runner' 'python-pip' 'python-jinja' 'python-click')
-source=($pkgname-$pkgver.tar.gz::https://github.com/textX/$_srcname/archive/$pkgver.tar.gz)
+checkdepends=('python-pytest-runner' 'python-pip' 'python-jinja' 'python-click' 'python-html5lib')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/textX/$_srcname/archive/$pkgver.tar.gz")
md5sums=('6d868822583d86f66cda71f40b1bebb5')
build() {
@@ -35,7 +34,13 @@ check() {
tests/functional/registration/projects/flow_dsl
tests/functional/registration/projects/flow_codegen)
for prj in "${prjs[@]}"; do
- pip install --user --no-index -f ./ -e "$prj" || exit 1
+ pip install \
+ --user \
+ --no-index \
+ --no-build-isolation \
+ --find-links ./ \
+ --editable \
+ "$prj" || exit 1
done
# Run all tests