diff options
author | gilcu3 | 2024-01-18 09:22:44 +0100 |
---|---|---|
committer | gilcu3 | 2024-01-18 09:22:44 +0100 |
commit | de6dc40ef79b824e5f135847bed64d632fec04d5 (patch) | |
tree | d2379a2e349eff08cc258b295c038a4e71f46ce6 /PKGBUILD | |
parent | 9b9ce331ed17e7b3d994ff924d8638e9faad112c (diff) | |
download | aur-de6dc40ef79b824e5f135847bed64d632fec04d5.tar.gz |
fix python wheel install
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 9 |
1 files changed, 2 insertions, 7 deletions
@@ -4,23 +4,18 @@ _pkgname=tflite-runtime pkgname=python-$_pkgname pkgver=2.14.0 -pkgrel=4 +pkgrel=5 pkgdesc='TensorFlow Lite Python bindings' arch=('x86_64') _py=cp311 url='https://www.tensorflow.org/lite/' license=('Apache') depends=('python-numpy') -makedepends=("python-pip") wheel_name=${_pkgname//-/_}-$pkgver-$_py-${_py}-manylinux2014_$arch.whl source=(https://files.pythonhosted.org/packages/$_py/${_pkgname::1}/$_pkgname/$wheel_name) sha256sums=('195ab752e7e57329a68e54dd3dd5439fad888b9bff1be0f0dc042a3237a90e4d') package() { - PIP_CONFIG_FILE=/dev/null pip install --isolated --upgrade --no-deps --ignore-installed --root=$pkgdir --no-warn-script-location --no-compile $wheel_name - cd $pkgdir - python -m compileall -d /usr "$pkgdir"/usr - python -O -m compileall -d /usr "$pkgdir"/usr - + python -m installer --destdir="$pkgdir" $wheel_name } |