summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorS0lll0s2015-06-01 16:18:24 +0200
committerS0lll0s2015-06-10 02:40:48 +0200
commita536179d396dbefea84e065f6513464fb844136c (patch)
tree3d3b9518957270e241f0a9540f2f828d7b1dda85 /PKGBUILD
downloadaur-a536179d396dbefea84e065f6513464fb844136c.tar.gz
Initial AUR4 check-in
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3513c2fb6e94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Charles Leifer
+# Maintainer: Sol Bekic <s0lll0s at blinkenshell dot org>
+
+_gitname=themer
+_gitbranch=master
+pkgname="python-${_gitname}-git"
+pkgdesc='Themer is a colorscheme generator and manager for your desktop.'
+pkgrel=2
+url="https://github.com/s0lll0s/${_gitname}"
+license=('MIT')
+arch=('any')
+depends=('python' 'python-pillow' 'python-yaml' 'python-jinja' 'python-requests')
+optdepends=('i3: default-supported windowmanager' 'fish: supports completion')
+makedepends=('git' 'python-setuptools')
+conflicts=()
+install="${_gitname}.install"
+source=("${_gitname}::git://github.com/s0lll0s/${_gitname}.git#branch=${_gitbranch}"
+ "${install}")
+sha256sums=('SKIP'
+ '3fc9aa9b92cbb7dbbc0b30323faf3744c30abb7d6d365331a5b8a623355987a5')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${_gitname}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}