summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJ. Nathanael Philipp2023-09-20 14:53:04 +0200
committerJ. Nathanael Philipp2023-09-20 14:53:04 +0200
commit082279a336a813688f28a33cd544a8111381d962 (patch)
tree615588cc208e1c6c9afeeb25491b4bda9068fefa /PKGBUILD
parentee0396b009a0bfd13b0fee86a3bc85978172d74e (diff)
downloadaur-082279a336a813688f28a33cd544a8111381d962.tar.gz
Version 8.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 4 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e90152cec03..e3711e31a80b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+# Maintainer: J. Nathanael Philipp (jnphilipp) <nathanael@philipp.land>
+# Contributor: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Philip Goto <philip.goto@gmail.com>
# Contributor: Chris Brendel <cdbrendel@gmail.com>
pkgname=python-thinc
_pkg="${pkgname#python-}"
-pkgver=8.1.7
+pkgver=8.2.0
pkgrel=1
pkgdesc='Practical Machine Learning for NLP'
arch=('x86_64' 'aarch64')
@@ -19,37 +20,19 @@ depends=(
'python-murmurhash'
'python-numpy'
'python-packaging'
- 'python-plac'
'python-preshed'
'python-pydantic'
- 'python-six'
'python-srsly'
- 'python-tqdm'
'python-wasabi')
makedepends=('cython' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
-# checkdepends=('python-pytest' 'python-hypothesis' 'python-mock')
source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/t/$_pkg/$_pkg-$pkgver.tar.gz")
-sha256sums=('0f08f6d1fc50e28bf18814ca2b1c807cd4d59a930d713459a675e086c4779af9')
-
-prepare() {
- cd "$_pkg-$pkgver"
- sed -i '18c\PACKAGES = find_packages(exclude=["thinc.tests*"])' setup.py
- sed -i '5,6d' MANIFEST.in
- rm -rf "$_pkg.egg-info"
-}
+sha256sums=('82ca1e7831e354d74c6776ed87dbd73f4aad59ed258c8746cbe868688186fc49')
build() {
cd "$_pkg-$pkgver"
python -m build --wheel --no-isolation --skip-dependency-check
}
-## FIXME tests dont import extensions properly
-# check() {
-# cd "$_pkg-$pkgver"
-# local _py="$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')"
-# PYTHONPATH="$PWD/build/lib.linux-$CARCH-cpython-$_py" pytest
-# }
-
package() {
cd "$_pkg-$pkgver"
python -m installer --destdir="$pkgdir" dist/*.whl