summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2022-07-18 17:52:36 +0200
committerPhilip Goto2022-07-18 17:52:36 +0200
commitc77f233d62008cbc36d821b5217842e5231efaf8 (patch)
tree5342f1c4d51a3ab2159873f3903ff292e35e7fad /PKGBUILD
parent2b5df144ab57d4c34a71d62772f9d7ea1c32b233 (diff)
downloadaur-c77f233d62008cbc36d821b5217842e5231efaf8.tar.gz
Update to 8.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cc01bebd373b..0b01a4b74ac7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=thinc
pkgname=python-${_pkgname}
-pkgver=8.0.17
+pkgver=8.1.0
pkgrel=1
pkgdesc='Practical Machine Learning for NLP'
arch=(x86_64 aarch64)
@@ -26,20 +26,26 @@ depends=(
python-wasabi
)
makedepends=(
- python-pip
- python-setuptools
+ python-build
+ python-installer
+ python-wheel
cython
)
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
-b2sums=('89179c7ebfa2d1eb1475be611bee9bd82900dc4093d9004a143ff4300cfb31458e41dd637332eb560321ba5216bc4e0f080390566110f5abda4933a201756ecc')
+b2sums=('a816b977a1ae6ec1bd69c6bf4f23f1aad8767b1947daf0f402af593607b6b37c586f487149aa3ee110b214d31d093387806698b5e2dfd1bc828c2adf25e73d96')
build() {
cd "thinc-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation --skip-dependency-check
}
package() {
cd "thinc-${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
}
+
+check() {
+ cd "thinc-${pkgver}"
+ # python -m pytest
+}