summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Brendel2018-10-30 02:42:49 -0700
committerChris Brendel2018-10-30 02:42:49 -0700
commite4c9606a12c31c0c9d2ea81c45f16b9229361698 (patch)
tree4135b97be26e8834f844d44401cec44603154e17 /PKGBUILD
downloadaur-e4c9606a12c31c0c9d2ea81c45f16b9229361698.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bcb3dcbc1e6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Chris Brendel <cdbrendel@gmail.com>
+# Python package author: Matthew Honnibal <matt@explosion.ai>
+pkgname=python-thinc
+_origpkgname=thinc
+pkgver=6.12.0
+pkgrel=1
+pkgdesc="Practical Machine Learning for NLP"
+arch=("x86_64")
+url="https://github.com/explosion/thinc"
+license=("MIT")
+depends=("cython"
+ "python-numpy"
+ "python-msgpack-numpy-git"
+ "python-cymem"
+ "python-preshed"
+ "python-murmurhash"
+ "python-plac"
+ "python-ujson"
+ "python-dill"
+ "python-pytest"
+ "python-mock"
+ "python-pathlib"
+ "python"
+ "python-hypothesis"
+ "python-cytoolz"
+ "python-blis"
+ "python-six"
+ "python-tqdm"
+ "python-wrapt"
+)
+makedepends=("python-setuptools")
+optdepends=("python-spacy: examples")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/explosion/thinc/archive/v$pkgver.tar.gz")
+md5sums=("e6ebce7e0a0c87a7f9d9470068f9be9a")
+
+package() {
+ cd "$_origpkgname-$pkgver"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}