summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaarten van Gompel2015-06-21 12:51:29 +0200
committerMaarten van Gompel2015-06-21 12:51:29 +0200
commitac463bd7052bba9135270b76d39b975c470bd0aa (patch)
tree5e8c3509df5e71051f9794c03c8bbb2d18976c53 /PKGBUILD
downloadaur-python-timbl-git.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e36fa24a002
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+_pkgname=python-timbl
+pkgname=${_pkgname}-git
+pkgver=48
+pkgrel=1
+pkgdesc='Python binding for Timbl, a k-Nearest Neighbours machine learning suite'
+arch=('i686' 'x86_64')
+url="https://github.com/proycon/python-timbl"
+license=('GPL')
+depends=('python' 'libxml2' 'boost' 'timbl' 'python-setuptools')
+makedepends=('git' 'libtool')
+provides=("${_pkgname}")
+source=("git://github.com/proycon/python-timbl.git")
+_gitname=("python-timbl")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git rev-list --count HEAD
+}
+
+
+build() {
+ cd "$srcdir/$_gitname"
+ python setup3.py build_ext --timbl-library-dir=/usr/lib --timbl-include-dir=/usr/include/ build
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup3.py build_ext --timbl-library-dir=/usr/lib --timbl-include-dir=/usr/include/ install --prefix=/usr --root="${pkgdir}"
+}