summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron DeVore2015-09-07 16:51:27 -0700
committerAaron DeVore2015-09-07 16:51:27 -0700
commit3d1ad12ac28f452e611fea74eb12ff61c17a3ec3 (patch)
tree9ea8f41a45e6530be989fae3c4f616b2999f20bb /PKGBUILD
parentae982ffe776c70b0513353765b122204745983ed (diff)
downloadaur-python-timelib.tar.gz
Version 0.2.4-2: Convert to split build, correct placement of `python setup.py install`
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c80c792c9b95..efc8b7a250ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,34 @@
# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
# Contributor: Mathieu Clabaut <mathieu.clabaut@gmail.com>
-pkgname=python-timelib
+pkgname=(python-timelib python2-timelib)
pkgver=0.2.4
-pkgrel=1
-pkgdesc="A library to parse english textual date descriptions [Python 3]"
+pkgrel=2
+pkgdesc="A library to parse english textual date descriptions"
arch=('i686' 'x86_64')
url="http://pypi.python.org/pypi/timelib"
license=(PHP custom)
-depends=('python')
source=("http://pypi.python.org/packages/source/t/timelib/timelib-$pkgver.zip")
md5sums=('400e316f81001ec0842fa9b2cef5ade9')
build() {
cd "$srcdir/timelib-$pkgver"
+ python setup.py build
+}
+
+package_python-timelib() {
+ depends=('python')
+ cd "$srcdir/timelib-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 README.rst \
+ "$pkgdir/usr/share/licenses/$pkgname/README.rst"
}
-package() {
+package_python2-timelib() {
+ depends=('python2')
cd "$srcdir/timelib-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
install -D -m644 README.rst \
"$pkgdir/usr/share/licenses/$pkgname/README.rst"
}
+