summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Handley2020-04-19 16:22:41 +0100
committerWill Handley2020-04-19 16:22:41 +0100
commitc6b8e7cb9bf357cfb832a4247cad13a46dff7ea1 (patch)
tree22790dd3370865f35a319f43a15bdf21af0fcbbe /PKGBUILD
downloadaur-c6b8e7cb9bf357cfb832a4247cad13a46dff7ea1.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ed3cc6f21ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+_modulename=todoist-python
+pkgname=python-$_modulename
+pkgver=8.1.1
+pkgrel=1
+pkgdesc="The official Todoist Python API library"
+arch=(any)
+url="https://github.com/Doist/$_modulename"
+license=('BSD')
+groups=()
+depends=('python-requests')
+makedepends=('python-setuptools')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=('009e8a5bb38e496ab7fafdb32e2dd6122f446cb10122da0a4e329c251a5897e9')
+package() {
+ cd "$srcdir/$_modulename-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}