summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredponike2025-03-04 00:05:39 +0100
committerredponike2025-03-04 00:05:39 +0100
commit99526d965bbee186abd8512e38c9725a3b87da77 (patch)
treed9324eb48f220279fa741a5cf196c8759ee4be4c /PKGBUILD
parent85ff421e7250cc379824fdc5892def3f036a105c (diff)
downloadaur-99526d965bbee186abd8512e38c9725a3b87da77.tar.gz
upgpkg: 0.2.5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48b639cf7819..1467378166c6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
+# Maintainer: redponike <proton (dot) me>
+
pkgname=python-torchdiffeq
-pkgver=0.2.3
+_pkgname=${pkgname#python-}
+pkgver=0.2.5
pkgrel=1
pkgdesc="Differentiable ODE solvers with full GPU support and O(1)-memory backpropagation. "
-depends=('python' 'python-pytorch' 'python-scipy')
-makedepends=('python-setuptools')
+depends=('python-pytorch' 'python-scipy' 'python-numpy')
+makedepends=('python-build' 'python-installer' 'python-wheel')
arch=('x86_64')
url="https://github.com/rtqichen/torchdiffeq"
license=('MIT')
-source=("https://files.pythonhosted.org/packages/61/7e/629146662e96da319fe237920b7d928a9832cbfa06c1d7ee8cdfe53ed450/torchdiffeq-0.2.3.tar.gz")
-sha256sums=('fe75f434b9090ac0c27702e02bed21472b0f87035be6581f51edc5d4013ea31a')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('b50d3760d13fd138dcceac651f4b80396f44fefcebd037a033fecfeaa9cc12e7')
build() {
- cd "${srcdir}/torchdiffeq-$pkgver"
- python setup.py build
+ cd "${_pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/torchdiffeq-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ cd "${_pkgname}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}