summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWill Handley2023-01-23 14:20:45 +0000
committerWill Handley2023-01-23 14:23:08 +0000
commit872406e831b088e815b92fbd2058ac71c8923d3b (patch)
tree9757e7d03d7d9430da3ee12cd44f9cd7ea948d1c /PKGBUILD
downloadaur-872406e831b088e815b92fbd2058ac71c8923d3b.tar.gz
0.1.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d63cd827d0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+pkgname=python-torchist
+_name=${pkgname#python-}
+pkgver=0.1.7
+pkgrel=1
+pkgdesc="The torchist package implements NumPy's histogram and histogramdd functions in PyTorch with support for non-uniform binning."
+arch=(any)
+url="https://github.com/francois-rozet/torchist"
+license=('MIT')
+groups=()
+depends=(python-pytorch)
+makedepends=(python-build python-installer)
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=(b02c580326ee48d21eed5dd0b78f3523c845fa27998c652faaae147752ad73c1)
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ touch requirements.txt
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+