summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2019-08-11 03:52:41 +0800
committerlilac2019-08-11 03:52:41 +0800
commitcd76e23db20665deb4c24ebfd3570b1473e20330 (patch)
tree38d4f877b6d383f03bece7eeb3c88b27c594e390 /PKGBUILD
parentc9a1f5780e437a14144dcdde90b93b76b660da7b (diff)
downloadaur-cd76e23db20665deb4c24ebfd3570b1473e20330.tar.gz
update by lilac
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd672f2fad1d..cecee4070723 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,17 +6,29 @@
pkgname=python-torchvision
_pkgname=vision
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=2
pkgdesc='Datasets, transforms, and models specific to computer vision'
arch=('x86_64')
-url=https://github.com/pytorch/vision
-license=(BSD)
-depends=(python-numpy python-pillow python-pytorch python-scipy python-six python-tqdm)
-makedepends=(python-setuptools)
-checkdepends=(python-pytest python-scipy)
+url='https://github.com/pytorch/vision'
+license=('BSD')
+depends=(
+ 'python-av'
+ 'python-numpy'
+ 'python-pillow'
+ 'python-pytorch'
+ 'python-scipy'
+ 'python-six'
+ 'python-tqdm'
+)
+makedepends=('python-setuptools')
+checkdepends=(
+ 'python-mock'
+ 'python-pytest'
+ 'python-scipy'
+)
source=("https://github.com/pytorch/vision/archive/v${pkgver}.tar.gz")
-sha512sums=('a402221827319c9792e7ff8edb8218737e09b8dade186a3b7adeb7501f2f60d030e0cc22e5b78163368056370daea4682da0748c72a736df0f4ee4443a8150fe')
+sha512sums=('e0443ec443b7fab0b67a674b4706a2d1145723c32ea81a44c1395a77877fb44787c86e0d271fbd295e4e577d6616ef8d0a2e3549015d5c5ae95182d5fd12c920')
build() {
cd "${_pkgname}-${pkgver}"