summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-06 17:15:02 +0000
committerDaniel Bermond2020-04-06 17:15:02 +0000
commit3ade3f80f7f3f8b56e7cc9dabfe4c283a4856574 (patch)
tree7a72828a40aa942dd666964e9b1870d27a746d14 /PKGBUILD
parent6be8bc75e4bc310015913c6dba3e012f2442c16f (diff)
downloadaur-3ade3f80f7f3f8b56e7cc9dabfe4c283a4856574.tar.gz
Updated to version 3.0.0
License changed from MIT to GPL3[1]. References ---------- https://github.com/rndusr/torf/commit/9b2fecaee33f93457202729582b1e7c6ee1cedc0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1465e6efb9fe..3e7eb27f9fbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,17 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=python-torf
-pkgver=2.1.0
+pkgver=3.0.0
pkgrel=1
pkgdesc='Python module to create, parse and edit torrent files and magnet links'
arch=('any')
url='https://github.com/rndusr/torf/'
-# NOTE: git master switched to GPL3
-# https://github.com/rndusr/torf/commit/9b2fecaee33f93457202729582b1e7c6ee1cedc0
-license=('MIT')
-depends=('python' 'python-bencoder-pyx')
+license=('GPL3')
+depends=('python' 'python-flatbencode')
makedepends=('python-setuptools')
-checkdepends=('python-pytest')
+checkdepends=('python-pytest' 'python-pytest-xdist')
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/rndusr/torf/archive/v${pkgver}.tar.gz")
-sha256sums=('30a488dc8df9df751cc56141a94c655cf5c85fca248422061c5ac50517ecdd47')
+sha256sums=('575a1ae9c01188ac7a02ef72ccffd56452af4de759ac8a953320440b9d4f78af')
build() {
cd "torf-${pkgver}"
@@ -28,5 +26,4 @@ check() {
package() {
cd "torf-${pkgver}"
python setup.py install --root="$pkgdir" --skip-build --optimize='1'
- install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}