summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2022-07-23 17:14:02 -0300
committerDaniel Bermond2022-07-23 17:14:02 -0300
commit9c69766b028d15a8f42dd944d4a6694395bb0ef6 (patch)
treeb4ed03609e464d1bfe9c2b1f8aeb61c30656279e /PKGBUILD
parent8df7a31289dcc4e59c6b651b3b29a554dcc50b4e (diff)
downloadaur-9c69766b028d15a8f42dd944d4a6694395bb0ef6.tar.gz
Update to vesion 4.0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a90d494bc867..12f4ce186b71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,28 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=python-torf
-pkgver=3.1.3
-pkgrel=2
+pkgver=4.0.3
+pkgrel=1
pkgdesc='Python module to create, parse and edit torrent files and magnet links'
arch=('any')
url='https://github.com/rndusr/torf/'
license=('GPL3')
depends=('python' 'python-flatbencode')
-makedepends=('python-setuptools')
-checkdepends=('python-pytest' 'python-pytest-xdist' 'python-pytest-httpserver')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+checkdepends=('python-pytest' 'python-pytest-httpserver' 'python-pytest-mock' 'python-pytest-xdist')
source=("https://github.com/rndusr/torf/archive/v${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('9952b1a273266facff279b6fa74d28605fe5978d277483f9218ff5cb1c24121f')
+sha256sums=('beb87d9fc227082e8cb1bbc1ea5315e701fb300418e8a1e89a0e53b098d11ce9')
build() {
cd "torf-${pkgver}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd "torf-${pkgver}"
- PYTHONPATH="$(pwd)/build/lib" pytest --file-counts='1' --piece-counts='1'
+ pytest --file-counts='1' --piece-counts='1'
}
package() {
- cd "torf-${pkgver}"
- PYTHONHASHSEED='0' python setup.py install --root="$pkgdir" --skip-build --optimize='1'
+ python -m installer --destdir="$pkgdir" "torf-${pkgver}/dist"/*.whl
}