diff options
author | zoorat | 2023-11-11 20:03:51 +0600 |
---|---|---|
committer | zoorat | 2023-11-11 20:03:51 +0600 |
commit | 2821eed6c6692975c8f5465af051946401cad397 (patch) | |
tree | c407492ec86b00b2370a9afaeb9c9f35a7679538 /PKGBUILD | |
parent | 7b5d0e50e17c6af5284a550806261e3bd5ef93eb (diff) | |
download | aur-2821eed6c6692975c8f5465af051946401cad397.tar.gz |
adding better tooling
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 37 |
1 files changed, 18 insertions, 19 deletions
@@ -1,35 +1,34 @@ -# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz> +# Maintainer: zoorat <zoorat [at] protonmail [dot] com> +# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz> # Contributor: peeweep <peeweep at 0x0 dot ee> -_pkgname='torrequest' -pkgname="python-${_pkgname}" - +pkgname="python-torrequest" +_name=${pkgname#python-} pkgver=0.1.0 -pkgrel=3 -_commit_readme='6cc228cd460dd119e053cf2168b94120be5c98d4' +pkgrel=4 pkgdesc='Simple Python interface for HTTP(s) requests over Tor' arch=('any') url='https://github.com/erdiaker/torrequest' -_url_pypi='https://pypi.org/project/torrequest' +# url='https://pypi.org/project/torrequest' license=('MIT') -# No licence file available upstream -depends=('python-pysocks' 'python-requests' 'python-stem') + +depends=('python' 'python-stem' 'python-pysocks' 'python-requests') makedepends=('python-setuptools') -source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz" - "${_pkgname}-readme-${_commit_readme}::${url}/raw/${_commit_readme}/README.md") +options=(strip emptydirs zipman) + +source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz" + "https://raw.githubusercontent.com/erdiaker/torrequest/master/README.md") sha256sums=('3745d4ea3ffda98d7a034363c787adb37aab77bdab40094a4d937392cd4dae82' - '820c985c4c1e943d35b92091c7b07c68ec7a45bb93b21e2881a09f976fbe6df2') + '820c985c4c1e943d35b92091c7b07c68ec7a45bb93b21e2881a09f976fbe6df2') build() { - cd "${_pkgname}-${pkgver}" - python setup.py build + cd "${_name}-${pkgver}" || exit + python setup.py build } package() { - install -Dvm644 "${_pkgname}-readme-${_commit_readme}" "${pkgdir}/usr/share/doc/${pkgname}/README.md" - cd "${_pkgname}-${pkgver}" - python setup.py install --root="${pkgdir}" --optimize=1 --skip-build + cd "${_name}-${pkgver}" || exit + python setup.py install --root="${pkgdir}" --optimize=1 --skip-build + install -Dvm644 "${srcdir}/README.md" "${pkgdir}/usr/share/doc/${pkgname}/README.md" } - -# vim: ts=2 sw=2 et: |