summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2017-07-14 18:10:47 -0400
committerGuillaume Horel2017-07-14 18:10:47 -0400
commit4d2a946f34b96ecd5dbeeae7044925c2e71cc869 (patch)
tree618fbedf005a3955f86d1e0ed63762acee678f69 /PKGBUILD
downloadaur-4d2a946f34b96ecd5dbeeae7044925c2e71cc869.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a55942b28ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-traittypes')
+_module='traittypes'
+pkgver='0.0.6'
+pkgrel=1
+pkgdesc="Traitlet types for NumPy, SciPy and friends."
+url="https://github.com/jupyter-widgets/traittypes"
+depends=('python'
+ 'python-traitlets'
+ 'python-numpy'
+ 'python-pandas')
+checkdepends=('python-pytest')
+makedepends=('python-setuptools')
+license=('BSD')
+arch=('any')
+source=("https://github.com/jupyter-widgets/traittypes/archive/${pkgver}.tar.gz")
+sha256sums=('8b2a8a68ef83aa8dc11a0e3b91f83cb3b9709089db85e3ca49aec990f644748c')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+
+check() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python -m unittest
+}