summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Fanninger2016-07-21 20:42:43 +0200
committerThomas Fanninger2016-07-21 20:42:43 +0200
commitf4457e5f632b5f9a304d426c1df8adb0d3e49738 (patch)
tree8a2e76adbc6b02b0fe3dfec300db406e049abdcc /PKGBUILD
downloadaur-f4457e5f632b5f9a304d426c1df8adb0d3e49738.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49fdcb4c30e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Thomas Fanninger <thomas@fanninger.at>
+# Maintainer: Thomas Fanninger <thomas@fanninger.at>
+
+pkgname=transwhat
+pkgver=0.2
+pkgrel=1
+epoch=1
+pkgdesc="A gateway between the XMPP and the WhatsApp IM networks"
+arch=('any')
+url="https://github.com/stv0g/transwhat"
+license=('GPL')
+provides=('transwhat')
+depends=('python' 'protobuf-python' 'python-pillow' 'python-dateutil' 'python-yowsup-git>=2')
+makedepends=('python-setuptools')
+options=('!strip' '!emptydirs')
+
+source=("git+http://github.com/stv0g/transwhat.git#branch=setuptools")
+sha512sums=(SKIP)
+
+package() {
+ cd "${srcdir}/${pkgname}"
+
+ python setup.py install --root="$pkgdir/"
+}