summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaul Irofti2021-04-20 17:35:27 +0300
committerPaul Irofti2021-04-20 17:35:27 +0300
commit4b6880e05c7c1dfaddf3637dbda61824a9187fda (patch)
tree103841ab58a8fd8e8dd15ebb854316938cbfd56f /PKGBUILD
downloadaur-4b6880e05c7c1dfaddf3637dbda61824a9187fda.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f91379c17b3d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Paul Irofti <paul@irofti.net>
+_name=tsnet
+pkgname="python-$_name"
+pkgver=0.2.2
+pkgrel=1
+
+pkgdesc="transient simulation in water networks using Method of Characteristics"
+url="https://github.com/glorialulu/TSNet"
+arch=('any')
+license=('MIT')
+
+depends=(python python-numpy python-scipy python-networkx python-pandas
+ python-matplotlib python-plotly python-wntr)
+makedepends=(python-setuptools python-pytest-runner)
+
+source=("https://files.pythonhosted.org/packages/source/t/${_name}/${_name}-${pkgver}.tar.gz")
+sha256sums=('363fc2cd3ac2529d0fedf24b272b394fb2292116984b3b27c9deb1dbe1d16670')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+
+# vim:set sw=2 et: