summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJuliette Monsel2021-08-02 12:17:02 +0200
committerJuliette Monsel2021-08-02 12:17:02 +0200
commit9387c610c88fd3f88befcc547d4a4d9ae17ea51b (patch)
tree3a1974e5f3c931c09d808cf901bbfc0813925fd3 /PKGBUILD
parent382c5275cd40134b5f9b84ea23e1d2176cebe895 (diff)
downloadaur-9387c610c88fd3f88befcc547d4a4d9ae17ea51b.tar.gz
New upstream release -- v0.12.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 637a42195baa..ac4805e5a81e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Juliette Monsel <j_4321 at protonmail dot com>
pkgname=('python-ttkwidgets')
-pkgver=0.11.0
+pkgver=0.12.0
pkgrel=1
pkgdesc="Collection of widgets for Tkinter's ttk extensions"
_name=ttkwidgets
@@ -8,16 +8,22 @@ arch=('any')
url="https://github.com/RedFantom/ttkwidgets"
license=('GPL3')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/RedFantom/$_name/archive/${pkgver}.tar.gz")
-sha512sums=('5598e048b9a324bc2fad28a45aef9bebf7f784143090f541625d63d99b351ba6c0d2352100a5a03597b8df8a92aacbf6e2fe35a865a4377ddc689d3144f8ea8d')
+sha512sums=('0face6cbb3d40f20c70d848c39c11b460a53a0866536e879c14d5b69d59e18414b54bcad163753481df9bc7ec226308774287b91ee2cdd2826e383b783fc4e93')
makedepends=('python-setuptools')
depends=('tk' 'python-pillow')
+checkdepends=(python-pytest)
build() {
- cd "$srcdir/$_name-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py build
}
+check() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ pytest -v
+}
+
package() {
- cd "$srcdir/$_name-${pkgver}"
+ cd "${srcdir}/${_name}-${pkgver}"
python setup.py install --root="$pkgdir/" --prefix=/usr --optimize=1 --skip-build
}