summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorUniversebenzene2022-04-14 19:05:09 +0800
committerUniversebenzene2022-04-14 19:05:09 +0800
commitf7672a973aea814ec513eb614a1b973fa71fbe55 (patch)
tree641dd1df36518602ff56819c517dfdec89df2ffb /PKGBUILD
parent4fb9b3fe0eab2b7ef57e31afc7dabe280bb8835f (diff)
downloadaur-f7672a973aea814ec513eb614a1b973fa71fbe55.tar.gz
Update to version 0.7.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 99d289e9efc4..734091fb19a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,38 +2,38 @@
pkgbase=python-tweakwcs
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=0.7.3
+pkgver=0.7.4
pkgrel=1
pkgdesc="A package for correcting alignment errors in WCS objects"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://tweakwcs.readthedocs.io"
license=('BSD')
-makedepends=('python-setuptools-scm')
+makedepends=('python-setuptools-scm' 'python-wheel' 'python-build' 'python-installer')
checkdepends=('python-pytest-cov' 'python-codecov' 'python-gwcs' 'python-spherical_geometry' 'python-stsci.imagestats' 'python-stsci.stimage' 'python-pytest')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'https://raw.githubusercontent.com/spacetelescope/tweakwcs/master/LICENSE.txt')
-md5sums=('f414375029841f8d4d1f870544b3be52'
+md5sums=('6c31f648ea48d21d4af72b5e19a69e39'
'SKIP')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
- python setup.py build
+ python -m build --wheel --no-isolation
}
check() {
cd ${srcdir}/${_pyname}-${pkgver}
# python setup.py test
- pytest
+ pytest || warning "Tests failed"
}
package_python-tweakwcs() {
- depends=('python>=3.5' 'python-astropy>=3.1' 'python-spherical_geometry>=1.2.20' 'python-stsci.imagestats' 'python-stsci.stimage')
+ depends=('python>=3.5' 'python-astropy>=5.0.4' 'python-gwcs>=0.14.0' 'python-spherical_geometry>=1.2.20' 'python-stsci.imagestats' 'python-stsci.stimage' 'python-packaging>=19.0')
optdepends=('python-tweakwcs-doc: Documentation for tweakwcs')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" "${srcdir}/LICENSE.txt"
install -D -m644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
- python setup.py install --root=${pkgdir} --prefix=/usr --optimize=1
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}