summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormutantmonkey2013-12-14 19:48:11 -0800
committermutantmonkey2013-12-14 19:48:11 -0800
commitd4281c99c96e96b25dbb514abb53a4073e42d210 (patch)
tree20d4d33051e240e6b9a0484fd82880f4cb33db6b /PKGBUILD
downloadaur-d4281c99c96e96b25dbb514abb53a4073e42d210.tar.gz
add python-twilio and python-socksipy-branch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e94f2e25488
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+pkgname=python-twilio
+pkgver=3.6.4
+pkgrel=3
+pkgdesc="A module for using the Twilio REST API and generating valid TwiML."
+arch=('any')
+url="https://github.com/twilio/twilio-python"
+license=('MIT')
+depends=('python' 'python-httplib2' 'python-socksipy-branch')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/source/t/twilio/twilio-${pkgver}.tar.gz"
+ 'LICENSE')
+sha256sums=('8a1e2059758204bacc206ce6bd63d7a0b0393e31e21a26ca5031bb1c80c0f4a5'
+ '17db7e6dddc3a621518f20dd4b35dac73f25160680d2a4858654eca1019bdea6')
+
+package() {
+ cd "$srcdir/twilio-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: