summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2022-04-15 10:45:05 -0600
committerMark Wagie2022-04-15 10:45:05 -0600
commitb8b54f8604b7fdfa17f298c69044c5daf0a40b76 (patch)
treea7448161c14f2cf135a3485e632cfc6c4fa13a9a /PKGBUILD
parent85e703125e8cbee91a2720949ffe8540d7cd4c68 (diff)
downloadaur-b8b54f8604b7fdfa17f298c69044c5daf0a40b76.tar.gz
standards based build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4512f85f4254..918a10558e10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
pkgname=python-types-setuptools
_name=${pkgname#python-}
pkgver=57.4.12
-pkgrel=1
+pkgrel=2
pkgdesc="Typing stubs for setuptools"
arch=('any')
url="https://github.com/python/typeshed"
license=('Apache')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
sha256sums=('415a1c23101a05da17eb66bed5d5a865702e5a69f74c66dbf1af643dce9492ab')
build() {
cd "$_name-$pkgver"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "$_name-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ python -m installer --destdir="$pkgdir" dist/*.whl
}