summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgesh2024-02-14 22:59:07 +0200
committergesh2024-02-15 13:34:07 +0200
commit116549f0742b359a7f92a79103e23ba6b0bc7773 (patch)
tree4bd679579340412ecb0e2044134dec76457ba4a2 /PKGBUILD
downloadaur-116549f0742b359a7f92a79103e23ba6b0bc7773.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1eb11cf065d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gesh <gesh@gesh.uni.cx>
+
+pkgname='python-types-tqdm'
+_module='types-tqdm'
+_src_folder='types-tqdm-4.66.0.20240106'
+pkgver='4.66.0.20240106'
+pkgrel=1
+pkgdesc="Typing stubs for tqdm"
+url="https://github.com/python/typeshed"
+depends=('python')
+makedepends=('python-build' 'python-installer' 'python-wheel')
+license=('Apache-2.0')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/de/89/deab00a2d1aa7e5d6e415dbf5ba7a2a444ac5f194f3fd24a0ca611d6864f/types-tqdm-4.66.0.20240106.tar.gz")
+sha256sums=('7acf4aade5bad3ded76eb829783f9961b1c2187948eaa6dd1ae8644dff95a938')
+
+build() {
+ cd "${srcdir}/${_src_folder}"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+
+ cd "${srcdir}/${_src_folder}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}