summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAkechiShiro2023-05-20 19:48:18 +0200
committerAkechiShiro2023-05-20 19:48:18 +0200
commit849b21042fdf5de8798226c6086ecc4e300a637c (patch)
tree052e60798599b79d3084ad36cf68160614da28d1 /PKGBUILD
parent8258dab60792a0002e5b3e18185788471ed5b521 (diff)
downloadaur-849b21042fdf5de8798226c6086ecc4e300a637c.tar.gz
Update checkdepends
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 2 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 24097ee649df..10119769c558 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,8 @@ license=(GPL)
depends=(python)
conflicts=()
provides=(python-ubi-reader)
-makedepends=(git python-pip python-build python-installer python-wheel python-setuptools python-poetry python-pytest python-pytest-cov)
-checkdepends=()
+makedepends=(git python-pip python-build python-installer python-wheel python-setuptools python-poetry)
+checkdepends=(python-pytest python-pytest-cov)
source=("git+https://github.com/onekey-sec/$_pyname")
sha256sums=(SKIP)
@@ -30,13 +30,6 @@ build() {
python -m build --wheel --no-isolation
}
-# Not working, tests should be made post_install I believe
-#check(){
-# cd "$srcdir/$_pyname"
-# # For pytest
-# pytest
-#}
-
package() {
cd "$_pyname"
python -m installer --destdir="$pkgdir" dist/*.whl