summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorevs-ch2018-09-18 11:19:21 +0200
committerevs-ch2018-09-18 11:19:21 +0200
commit7f1ed74fd3ea5329e3830ec88e2806772099ae76 (patch)
treec3e120a9483e6bc7acbe53c54a1e4aefa622f0cf /PKGBUILD
downloadaur-7f1ed74fd3ea5329e3830ec88e2806772099ae76.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1968aecf8b52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: lsf
+pkgname=python-unicode-slugify-git
+_pkgbase=unicode-slugify
+pkgver=r41.8a9c3dc
+pkgrel=1
+pkgdesc="A Python slugify application that handles unicode"
+arch=(any)
+url="https://github.com/mozilla/unicode-slugify"
+license=('BSD')
+makedepends=("python-setuptools" "git")
+depends=("python" "python-unidecode" "python-six")
+source=("git+https://github.com/mozilla/unicode-slugify")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgbase"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgbase"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_pkgbase"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}