summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2022-01-23 22:01:02 +1100
committerMatthew Gamble2022-01-23 22:01:02 +1100
commita23b5eaa325381571f6714d72de9b460105d7bfe (patch)
tree046d9ca7cbdcdef4222e844fb506ebb89d94482f /PKGBUILD
parentfef8874252bf1a077520b19607686ba2ba52c774 (diff)
downloadaur-a23b5eaa325381571f6714d72de9b460105d7bfe.tar.gz
Bump pkgrel for python3.10 rebuild, other cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 12 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de9619e1b81a..ee19ff4e803e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,27 @@
pkgname=python-unstdlib
pkgver=1.7.2
-pkgrel=2
+pkgrel=3
pkgdesc="Unstandard Python library of useful and highly-reusable functions."
arch=("any")
url="https://github.com/shazow/unstdlib.py"
license=("MIT")
depends=("python")
makedepends=("python-setuptools")
-source=("https://files.pythonhosted.org/packages/ad/bd/420390e57167f667caa206576f715964b11ef20894d4b69455e425fe21c6/unstdlib-1.7.2.tar.gz")
+source=("https://pypi.io/packages/source/u/unstdlib/unstdlib-${pkgver}.tar.gz")
sha256sums=("ef702a49bea7cefde837b7419f02d0b6274823cc51801ef5b9ba4ccb60227eb0")
+build() {
+ cd "unstdlib-${pkgver}"
+
+ python setup.py build
+}
+
package() {
cd "unstdlib-${pkgver}"
- python setup.py install --root="${pkgdir}"
+
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/python-unstdlib/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/python-unstdlib/README.md"
}