summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVictor Engmark2018-02-02 16:13:49 +1300
committerVictor Engmark2018-02-02 16:13:49 +1300
commit6c14803811690839a307faa691286fbc4045231d (patch)
treed658407e9851fe8973b4dde0d0f772a87aa07ceb /PKGBUILD
downloadaur-6c14803811690839a307faa691286fbc4045231d.tar.gz
Build vcard validator Python package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..43378faadeae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Victor Engmark <victor.engmark@gmail.com>
+pkgname=python-vcard
+_name="${pkgname#*-}"
+pkgver=0.10.2
+pkgrel=1
+pkgdesc="vCard validator"
+arch=('any')
+url='https://github.com/l0b0/vcard'
+license=('GPL3')
+depends=('python' 'python-isodate')
+makedepends=('python')
+provides=("${pkgname}")
+conflicts=("${pkgname}-git")
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
+sha512sums=('7fdcdccbe6c27f059c79169b652a84265741d96b1f242929b2406462f0bbd8ab3d071653fcb0ca4b29ea5a8d2763a8c4b89f23b22fbcb0537e5281f4621f380e')
+
+package() {
+ cd "$srcdir/${_name}-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}