summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuentin Bourgeois2016-11-26 12:38:50 +0100
committerQuentin Bourgeois2016-12-02 01:15:06 +0100
commit8f2d324379461084a0a70ecaa5abfd1528c38bb7 (patch)
treea74b0421b9fd7f5b7bb1dd9a1c2dea55e6c3f6e0 /PKGBUILD
parent71e186cd9adc817121d9d5bd634bb15575bef950 (diff)
downloadaur-8f2d324379461084a0a70ecaa5abfd1528c38bb7.tar.gz
<PKGBUILD: Add some dependencies for testing and doc building>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 19 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 935a93113a65..3694c7323c15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ groups=()
depends=()
makedepends=()
optdepends=('inkscape: tools for manipulating vector objects (eg: SVG files)')
-checkdepends=('python-tox' 'python-pylint' 'python2-tox' 'python2-pylint')
+checkdepends=()
provides=()
conflicts=()
replaces=()
@@ -51,8 +51,15 @@ package_python-viivakoodi() {
depends+=('python' 'python-argparse')
makedepends+=('python-setuptools')
provides+=('python2-viivakoodi')
- optdepends+=('python-pillow')
-
+ optdepends+=('python-sphinx: for building the project documentation'
+ 'python-sphinx-alabaster-theme: for building the project documentation'
+ 'python-pillow')
+ checkdepends+=('python-pylint'
+ 'python-pytest'
+ 'python-pytest-cov'
+ 'python-pytest-xdist'
+ 'python-mock'
+ 'python-tox')
cd "$srcdir/$_pylibname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
@@ -69,7 +76,15 @@ package_python2-viivakoodi() {
depends+=('python2>=2.6' 'python2-argparse')
makedepends+=('python2-setuptools')
provides+=('python2-viivakoodi')
- optdepends+=('python2-pillow')
+ optdepends+=('python2-sphinx: for building the project documentation'
+ 'python2-sphinx-alabaster-theme: for building the project documentation'
+ 'python2-pillow')
+ checkdepends+=('python2-pylint'
+ 'python2-pytest'
+ 'python2-pytest-cov'
+ 'python2-pytest-xdist'
+ 'python2-mock'
+ 'python2-tox')
cd "$srcdir/$_pylibname-$pkgver"
python2 setup.py install --root="$pkgdir/" --optimize=1