summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2024-01-09 20:18:42 +0800
committerlilac2024-01-09 20:18:42 +0800
commitd23e573d7c3d7c345f5164bf2a5ae8d890fc5005 (patch)
treec74570b83c464681c5a001fbbab36e00e1a85bf6 /PKGBUILD
parent5f98a92e050395d1223c4bc7278e5b3bffffab6e (diff)
downloadaur-d23e573d7c3d7c345f5164bf2a5ae8d890fc5005.tar.gz
[lilac] updated to 0.2.4-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1cd2be28aa07..d322021dba47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=python-visdom
_name=visdom
pkgver=0.2.4
-pkgrel=2
+pkgrel=4
pkgdesc='A flexible tool for creating, organizing, and sharing visualizations of live, rich data. Supports Torch and Numpy.'
arch=(any)
url='https://github.com/facebookresearch/visdom'
@@ -16,6 +16,7 @@ depends=(
python-requests
python-scipy
python-six
+ python-tornado
python-tqdm
python-websocket-client
)
@@ -38,5 +39,8 @@ build() {
package() {
cd "${_name}-${pkgver}"
python -m installer --destdir="${pkgdir}" dist/*.whl
+ # pre-download scripts
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ PYTHONPATH="${pkgdir}${site_packages}" python -c 'from visdom.server.build import download_scripts; download_scripts()'
}
# vim:set ts=2 sw=2 et: